RadarURL
Skip to content
조회 수 1283 추천 수 0 댓글 0
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄
?

단축키

Prev이전 문서

Next다음 문서

크게 작게 위로 아래로 댓글로 가기 인쇄

● L3 장애 시나리오 작성
- 본 문서는 장애 시나리오 발견시 지속적으로 업데이트 예정

● 시나리오 구성도
- L3에는 두개의 VLAN 설정(시리얼대역, 서비스대역)
- L2 스위치는 같은 VLAN으로 설정 (서비스대역)
- L3간에는 HA통신(VLAN1, VLAN10)을 위해 Trunk로 연결
- Loop 방지하기 위해 STP 설정(Active에 root Primary로 설정, Standby에 root Secondary 설정)
- VLAN1 : Active - 10.10.10.2, Standby - 10.10.10.3
- VLAN10 : Active - 172.16.1.2, Standby - 172.16.1.3

01.jpg

 


● 장애 시나리오
1. 1번 라인 장애
2. 2번 라인 장애
3. 3번 라인 장애
4. Active 장비 장애


● 장애 해결 방안
1. 장애1,2,3에 대해서는 한 라인이라도 장애 발생시 Active->Standby로 장비 이전
2. 장애4번은 Active->Standby로 장비 이전


● L3 Config 작성
1. HSRP
- Active Config

- interface Vlan1 -> 테스트에서는 fa1/0
- ip address 10.10.10.2 255.255.255.0
- standby 1 ip 10.10.10.1
- standby 1 priority 120
- standby 1 track FastEthernet1/0 20
- standby 1 track FastEthernet1/1 20
- standby 1 track FastEthernet1/2 20
- standby 1 authentication cloud

- interface Vlan10 -> 테스트에서는 fa1/1, fa1/2
- ip address 172.16.1.2 255.255.255.0
- standby 10 ip 172.16.1.1
- standby 10 priority 120
- standby 10 track FastEthernet1/0 20
- standby 10 track FastEthernet1/1 20
- standby 10 track FastEthernet1/2 20
- standby 10 authentication cloud

- Standby Config
- interface Vlan1 -> 테스트에서는 fa1/0
- ip address 10.10.10.3 255.255.255.0
- standby 1 ip 10.10.10.1
- standby 1 priority 110
- standby 1 authentication cloud

- interface Vlan10 -> 테스트에서는 fa1/1, fa1/2
- ip address 172.16.1.3 255.255.255.0
- standby 10 ip 172.16.1.1
- standby 10 priority 110
- standby 10 authentication cloud

2. STP
- Active Config
- spanning-tree vlan 1 root primary
- spanning-tree vlan 10 root primary

- Standby Config
- spanning-tree vlan 1 root secondary
- spanning-tree vlan 10 root secondary


3. HA 통신용 Trunk -> 테스트에서는 fa1/15
- Active, Standby Config
- interface fastEthernet 1/15
- switchport mode trunk
- switchport trunk encapsulation dot1q

● L2 Config
- SW01
- interface Vlan10 -> 모든포트 VLAN10
- Active Port : fa1/14
- Standby Port : fa1/15
- ip address 172.16.1.10 255.255.255.0
- ip default-gateway 172.16.1.1

- SW02
- interface Vlan10 -> 모든포트 VLAN10
- Active Port : fa1/14
- Standby Port : fa1/15
- ip address 172.16.1.20 255.255.255.0
- ip default-gateway 172.16.1.1


● HSRP 설정 정보
- Active

02.jpg

 


- Standby

03.jpg

 


● STP 설정 정보

- SW01 : Active가 살아있는 경우 fa1/15를 blocking

04.jpg

 


- SW02 : Active가 살아있는 경우 fa1/15를 blocking

05.jpg

 


● 장애 1,2,3 테스트
- Active에서 fa1/0, fa1/1, fa1/2 강제 셧다운
- 현재 Priority는 정상적으로 낮아지나 Active -> Standby로 넘어가지 않는 문제 확인 -> 버그인지 설정문제인지 확인 필요
- L2에서 STP설정 확인시 정상적으로 fa1/15가 blocking -> forwarding로 변경 확인
- L2에서 Gateway로 ping 가지 않음

06.jpg

 

 

06.jpg

 

 

08.jpg

 

 

● 장애4 테스트
- Active 장비 셧다운
- 동작 정상 -> STandby가 Active로 변경
- L2에서 Gateway로 ping 정상 -> port 올라오는 시간동안은 ping이 빠지는것 확인

09.jpg

 

 

10.jpg

 


● HSRP와 STP는 별도로 세팅되고 운영된다.
- HSRP에서 Active -> Standby로 넘어갈시 STP는 Active 장비가 셧다운되지 않는 이상 넘어가지 않는다.
- 1번 라인에 장애가 발생할 경우 HSRP의 Active -> Standby로 넘어가지만 STP는 문제가 없으므로 L2단에서는 기존 Active로 패킷이 넘어간뒤
다시 Standby로 패킷이 넘어가는 형태가 된다.


● 현재 GNS3로 테스트하는데에는 버그가 있을수있고 config가 정상적으로 작동안할수도 있기때문에
기본적인 테스트만 가능해보인다.
추후 장비가 입고된뒤 실제로 HSRP 테스트를 진행해야 할듯하다.

 

출처 : http://lovevirus133.tistory.com/147

?

List of Articles
번호 제목 글쓴이 날짜 조회 수
23 STP (스패닝 트리 프로토콜) JAESOO 2017.11.14 570
22 [스위치] 스패닝 트리 ( STP - Spanning Tree Protocol ) JAESOO 2017.11.10 238
21 STP(Spanning-Tree Protocol) 동작원리 JAESOO 2017.11.08 223
20 H514G 모뎀 대신 사용가능한 허브 iptime H5005-IGMP JAESOO 2015.08.28 1421
19 케이블 교체 공사없이 제공되는 기가급 (300~500Mbps) 인터넷 서비스란? JAESOO 2015.08.28 743
18 [네트워크 트러블 슈팅 ④] 네트워크 장비별 트러블 슈팅 JAESOO 2015.06.15 807
17 백본스위치(backbone switch)란? JAESOO 2015.06.15 4405
» Cisco L3 이중화 - 2. 장애 시나리오 및 테스트 JAESOO 2015.06.15 1283
15 [White Paper] 업무연속성과 해재복구 계획 수립 JAESOO 2015.06.15 203
14 Switch , VLAN , VTP JAESOO 2015.06.15 391
13 Switch의 Loop방지기술 - STP JAESOO 2015.06.15 392
12 Router 와 L3 Switch의 차이 JAESOO 2015.04.16 1129
11 스위치 성능인 PPS(Packet per Sec, 초당 처리 가능한 최대 패킷 수) 계산법 JAESOO 2014.11.27 657
10 PPS(Packet per Sec, 초당 처리 가능한 최대 패킷 수) 계산법 JAESOO 2014.11.27 2473
9 [Switch 기능] STP, RSTP, MSTP에 관해서… JAESOO 2014.10.21 1244
8 네트워크 장비 L2 · L3 · L4 · L7 JAESOO 2014.10.20 1235
7 STP보호기술 2 - BPDU Filtering 와 Loop Guard JaeSoo 2014.03.24 877
6 STP보호기술 1 - BPDU Guard 와 Root Guard JaeSoo 2014.03.24 825
5 loop방지 및 STP 보호기술 (Spanning tree) JaeSoo 2014.03.24 864
4 CISCO 2960G 에 port mirroring 설정하기 JaeSoo 2014.03.21 5655
Board Pagination Prev 1 2 Next
/ 2

PageViews   Today : 1,258   Yesterday : 1,375   Total : 19,755,870  /  Counter Status   Today : 353   Yesterday : 339   Total : 1,407,213
Site Info   Member : 230  /  Total documents : 1,223   New documents : 0  /  Total comments : 24

Edited by JAESOO

sketchbook5, 스케치북5

sketchbook5, 스케치북5

나눔글꼴 설치 안내


이 PC에는 나눔글꼴이 설치되어 있지 않습니다.

이 사이트를 나눔글꼴로 보기 위해서는
나눔글꼴을 설치해야 합니다.

설치 취소